Xfce Wiki

Sub domains
 

Site Tools


This is an old revision of the document!


GTK+ 3 preparation and optional compile support

Default to GTK+ 2 in 4.12

Porting the entire desktop to GTK+ 3 is not going to happen in Xfce 4.12, it will be a more subtle approach. Xfce 4.12 has the following targets:

  • Core needs to be GSEAL complaint.
    • xfce4-dev-tools will enable -DGSEAL_ENABLE when compiling with full debugging.
  • Stop using custom and deprecated widgets.
    • xfce4-dev-tools will enable -DGTK_DISABLE_DEPRECATED when compiling with full debugging.

Partly support GTK+ 3

Eventually Xfce has to work with to GTK+ 3, so we can optionally support this in a couple of applications to make the migration quicker and it becomes easier to track the status of GTK+ 3. This involves the following tasks:

  • Allow building parallel GTK+ 2 and 3 libraries for libxfce4ui and exo.
  • Core components can optionally compile against GTK+ 3 for testing.

Depending on the time we'll see how this goes, but it give everybody the opportunity to work on this during the 4.12 release cycle. Keep in mind that GTK+ 2 is still the target for Xfce 4.12, so this should work at all times.

releng/4.12/roadmap/gtk3.1348054819.txt.gz · Last modified: 2012/09/19 13:40 by nick