Xfce Wiki

Sub domains
 

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
releng:4.10:roadmap:exo [2011/06/16 23:24]
nick [Remove hard-coded applications for preferred applications]
releng:4.10:roadmap:exo [2012/05/02 10:46]
nick [Remove hard-coded applications for preferred applications]
Line 2: Line 2:
 Basically the entire library was cleaned up in 4.8, so it doesn't need any big work this release. Basically the entire library was cleaned up in 4.8, so it doesn't need any big work this release.
  
-===== Mime-type Editor ===== 
-Allow editing the mimetyes in the preferred applications dialog (bug [[http://bugzilla.xfce.org/show_bug.cgi?id=6113|#6113]]). 
  
-Completed: 0%\\ +===== [FOR 4.12] Remove hard-coded applications for preferred applications =====
-Asignees: Jannis\\ +
-Difficulty: Easy +
- +
-===== Remove hard-coded applications for preferred applications =====+
 Right now the preferred application helper installs a set of 'known' applications so certain cagagories. This works fine-ish, but if the user for example uses a web browser that is not in this set, he/she needs to manually set it. Instead it should look for installed desktop files that provides a special mimetype or category. Right now the preferred application helper installs a set of 'known' applications so certain cagagories. This works fine-ish, but if the user for example uses a web browser that is not in this set, he/she needs to manually set it. Instead it should look for installed desktop files that provides a special mimetype or category.
  
Line 16: Line 10:
 Difficulty: Easy Difficulty: Easy
  
-===== Drop support library =====+===== [FINISHED] Drop support library =====
 Exo had a small support library for widget in libxfcegui4. The idea behind this was to keep it around until libxfce4ui was born. This library is around since 4.8, so now it is used in exo as well (libxfce4ui is a new exo dependency!). Exo had a small support library for widget in libxfcegui4. The idea behind this was to keep it around until libxfce4ui was born. This library is around since 4.8, so now it is used in exo as well (libxfce4ui is a new exo dependency!).