Xfce Wiki

Sub domains
 

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
releng:4.14:roadmap:xfce4-power-manager [2015/03/14 21:57] – [Port to Gtk3] ochosireleng:4.14:roadmap:xfce4-power-manager [2015/05/26 00:31] (current) ochosi
Line 3: Line 3:
 ===== Port to Gtk3 ===== ===== Port to Gtk3 =====
  
-Related branchhttp://git.xfce.org/users/eric/xfce4-power-manager/log/?h=gtk3\\ +Released1.5.0\\ 
-=== TODO=== +AssigneeEricSimon\\ 
-  * Drop LXDE panel plugin code (no support for Gtk3 plugins there) +Completed: 100%
-  * Fix more warnings from the settings dialog (deprecated properties of GtkAlignment) +
-  * Fix warning for missing GtkStyleContext in the panel plugin (run panel from terminal to see) +
-  * Consider replacing GtkTreeview in the devices tab with GtkListBox. +
-  * Use dedicated application icon name (instead of ac-adapter) +
-  * <del>Keeping the panel-plugin's menu open for a longer period of time makes the device-icons disappear (likely an issue with how these menuitems are updated)</del> +
-  * <del>Consider working around the padding on the left in the panel-plugin's menu</del> +
-  * <del>Fix [[https://code.launchpad.net/~larsu/ido/prelight-and-focus-scale/+merge/252293|hover-effect on the scale's button]]</del> +
-  * <del>Show frames in devices tab</del> +
-    * Showing the notebook border doesn't work +
-    * gtk_notebook_set_show_border (GTK_NOTEBOOK (device_details_notebook)TRUE); +
-      * Not really a problem with Adwaita, so maybe we should rely on themes to handle this +
-  * <del>Consider following UPower's naming scheme for battery icons</del> +
-    * Advantagemore icon themes support us out of the box +
-    * Disadvantage: we lose a state, now we have 6 states (00,20,40,60,80,100), UPower only has 5 states (empty, caution, low, good, full) +
-      * [[http://cgit.freedesktop.org/upower/tree/src/up-device.c#n206|upower implementation]] +
-  * <del>Fix scroll-event on plugin to change brightness</del> +
-  * <del>Port brightness icon to symbolic icon</del> +
-  * <del>Fix brightness icon not being shown</del> +
-  * <del>Port panel icons to symbolic icons</del> +
 ===== Port to gdbus ===== ===== Port to gdbus =====
  
-Assignee: Peter+Released: 1.5.0\\ 
 +Assignee: Peter\\ 
 +Completed: 100%
  
-Related branch: To be pushed.+=== TODO === 
 +  * Use g_dbus_own_name? 
 +    * The is asynchronous and handles aquire and loss. 
 +    * It doesn't support "do not queue" for that same reason. 
 +  * Use g_dbus_watch_name? 
 +    * In many cases we could drop the name check completely. 
 +  * Use gdbus-codegen proxies for all proxies? 
 +    * This might brings some overhead as it registers to everything of that proxy. 
 +    * It only brings a wrapper for the calls which split the first layer of GVariant.